IIS5.0 su MS Windows XP Home


Mi è capitato di dover installare
sul mio povero portatile Acer 1302 xc (che in dotazione porta win
XP Home Edition) Internet Information Server, con brivido e terrore
ho scoperto che il CD di XP Home (sia quello originale che quello
in dotazione con il recovery) non ha IIS 5.0 come opzione da poter
installare.

Contattando MS mi sono accorto che il supporto sembrava un nastro
registrato: "upgrade your system to XP Pro" alla fine
sembrava un’ordine!

Indeciso se spendere 300 comodi euro per la licenza di XP pro,
copiarlo, e workaroundarlo mi son buttato come sempre sulla via
più difficile, ed eccoci al risultato:

Nella vostra installazione normale di XP Home Edition trovate ed
aprite (con notePad) il file c:windowsinfsysoc.inf (non ricordo
se sia nascosto o meno).
Alla voce [components] dovreste trovare una dicitura come segue:

iis=iis.dll,0cEntry,iis.inf,hide,7

Sostituitela con questa:

iis=iis_new.dll,0cEntry,iis_new.inf,,7

Poi ho preso i file iis.dl_ ed
iis.in_
dal CD di installazione di Win 2k utilizzando
il comando:

expand iis.dll iis_new.dll

dal prompt dei comandi e lo stesso per iis.in_
in iis2.inf nelle cartelle c:windowsinf
per iis_new.inf e c:windowssystem32setup per iis_new.dll
Ora se andate nel menù di installazione applicazioni alla
voce aggiungi componenti di windows del pannello di controllo vi
ritroverete la possibilità di installare IIS (mettere la
spunta) al momento dell’ OK comincia ad installare i file di sistema,
la cosa richiede un po’ di tempo in quando alcuni file sono nel
CD di XP home mentre altri nel CD di Win2k.
Che altro dire… non ci rimane molto altro se non quello di concludere
l’installazione, una volta finita io ho riavviato la macchina anche
se non son convinto che sia strettamente necessario. Dal menù
strumenti di amministrazione non vi resta altro che accedere alla
MMc di IIS.
Mi è capitato (solo la prima volta che ho fatto l’installazione)
che non funzioni la pagina iniziale lanciando da Internet Explorer
http://localhost, non è un grave propblema perchè
se andate sull’amministrazione del Web Service nel cavaliere "security"
andate nel pulsante modifica e sfogliate gli utenti ed i gruppi
locali del computer, aggiungete everyone e tutto andrà per
il meglio (o per lo meno funzionante).

Questo workaround non è certificato, non è ufficiale
e non è dotato di supporto, potete chiedermi ulteriori specifiche
nel forum di questo thread ma ricordate che questa installazione
è stata effettuata soltanto 2 volte sullo stesso portatile,
diciamo che la casistica è abastanza ristretta :-)

IIS5.0 su MS Windows XP Home ultima modifica: 2003-06-04T00:00:00+00:00 da Enrico

Related Posts

Comments are closed.